Detectan vulnerabilidades críticas en el escritorio remoto de Apache

Vulnerabilidad en el escritorio remoto de Apache

En muchas ocasiones surgen fallos de seguridad que pueden poner en riesgo nuestros sistemas y dispositivos. Esto es algo que puede afectar tanto a usuarios particulares como también a organizaciones. En este artículo nos hacemos eco de importantes vulnerabilidades de seguridad que afectan a Apache y su popular escritorio remoto, Apache Guacamole. Hay que tener en cuenta que es compatible con todos los protocolos estándar como VNC, RDP y SSH.

Importantes vulnerabilidades en Apache Guacamole

Como decimos, han detectado importantes vulnerabilidades de seguridad que afectan a Apache Guacamole. Estos fallos han sido descubiertos por investigadores de seguridad de Check Point y han sido registradas como CVE-2020-9498 y CVE-2020-9497.

Hay que mencionar que Apache Guacamole es muy popular. No requiere complementos ni software de cliente y eso hace que cuente con más de 10 millones de descargas en todo el mundo. Esto significa que son muchos los usuarios que podrían verse afectados por estos problemas.

Desde Check Point han informado de que descubrieron que algunas características de Guacamole no cumplían con los estándares de seguridad que se requiere. En concreto era vulnerable a varios fallos críticos de RDP inverso, y estaba afectado por múltiples vulnerabilidades nuevas encontradas en FreeRDP.

Estas vulnerabilidades podrían permitir a un posible intruso comprometer un equipo dentro de una organización y posteriormente conectarse de nuevo a través de un trabajador desprevenido.

Esto daría a los atacantes la posibilidad de obtener el control total sobre el servidor de Guacamole y obtener el control de todas las sesiones. Las vulnerabilidades afectan tanto a FreeRDP como a Apache Guacamole.

Cómo actúan estas vulnerabilidades

Respecto a la vulnerabilidad CVE-2020-9497, se trata de una validación de entrada incorrecta de canales virtuales estáticos RDP. Afecta a Apache Guacamole 1.1.0 y versiones anteriores.

Si un usuario se conecta a través de un servidor RDP malintencionado o comprometido, entonces los datos especialmente diseñados pueden dar lugar a la divulgación de información dentro de la memoria del proceso guacd que maneja la conexión.

Por otra parte está la vulnerabilidad CVE-2020-9498. En este caso el fallo se debe a que Apache Guacamole 1.1.0 y versiones anteriores manejan mal las indicaciones recibidas a través de canales virtuales estáticos RDP.

En caso de que un usuario se conectara a un servidor RDP malintencionado o comprometido, una serie de PDU especialmente diseñadas pueden provocar daños en la memoria, podrían permitir la ejecución de código arbitrario con privilegios ejecutando el proceso guacd.

Como vemos, una vez más estamos ante vulnerabilidades que pueden poner en riesgo nuestra seguridad y privacidad. Es vital que siempre contemos con las últimas versiones disponibles. Son muchas las ocasiones en las que aparecen fallos que pueden ser explotados por piratas informáticos con el objetivo de robar nuestros datos e infectar los equipos.

Nuestro consejo siempre es mantener los dispositivos actualizados correctamente. Esto es algo que debemos aplicar en todo momento si queremos estar seguros. Hemos visto que estas vulnerabilidades afectan al servidor Apache. Os dejamos un artículo donde damos algunos consejos para mantener seguros los servidores.

El artículo Detectan vulnerabilidades críticas en el escritorio remoto de Apache se publicó en RedesZone.

Powered by WPeMatico

Gustavo Genez

Informático de corazón y apasionado por la tecnología. La misión de este blog es llegar a los usuarios y profesionales con información y trucos acerca de la Seguridad Informática.