Vulnerabilidad sin parchear permite secuestrar routers Centurylink

Para la explotación del fallo, el cual se reportó hace casi 5 meses, sólo es necesaria una petición al dispositivo sin credenciales.

Investigando si los routers de Centurylink cuentan con protección contra falsificación de peticiones en sitios cruzados (del inglés ‘Cross-Site Request Forgery’ o CSRF), el grupo de seguridad Lykosec encontró que no sólo estos routers no estaban implementando dicha medida de seguridad, sino que también era posible realizar peticiones sin autenticarse.

Al no requerirse autenticación, sólo es necesario saber la ruta y los parámetros a enviar al router para tomar el control. Una de ellas, ‘/advancedsetup_admin.cgi’ con el parámetro ‘adminPwState=0’ como un formulario por ‘POST’ permite deshabilitar la contraseña del administrador, facilitando tomar el control del router. No obstante, al no comprobarse las credenciales puede haber otras formas de secuestrar el dispositivo.

Debido a su fácil explotación, el ataque podría realizarse de diferentes maneras. La más obvia es conectándose a la red, por ejemplo por WiFi, aunque también es posible si la administración del router está expuesta en Internet. Otra forma es, por ingeniería social, lograr que un usuario dentro de la red mande la petición del formulario aprovechando que no hay protección CSRF.

La vulnerabilidad fue reportada el 9 de diciembre del pasado año, siendo asignado el identificador CVE 2019-19639. El día 13 del mismo mes fue confirmado por el fabricante, y el día 27 de febrero de este año aseguraba estar probando una versión interna parcheada. Se volvió a contactar dos veces más solicitando novedades al respecto, hasta el pasado día 5 de mayo en que la vulnerabilidad se publicó, sin existir una versión que solucione el fallo.

La vulnerabilidad ha sido comprobada en el router Centurylink C3000A (también bajo la marca Actiontec) , aunque lo más probable es que haya bastantes más modelos afectados, al compartir el mismo software. Debido a la gravedad de la vulnerabilidad, se recomienda actualizar tan pronto como exista una versión que solucione el fallo.

Más información:

CVE 2019-19639: Hijacking Centurylink Routers:
https://www.lykosec.com/post/cve-2019-19639-hijacking-centurylink-routers

Powered by WPeMatico

Gustavo Genez

Informático de corazón y apasionado por la tecnología. La misión de este blog es llegar a los usuarios y profesionales con información y trucos acerca de la Seguridad Informática.