Vulnerabilidades de inyección SQL en phpMyAdmin

Fecha de publicación: 24/03/2020

Importancia:
Alta

Recursos afectados:

phpMyAdmin, versiones 4.9.x anteriores a 4.9.5, y versiones 5.0.x anteriores a 5.0.2.

Descripción:

Los investigadores hoangn144_VCS, bluebird y Yutaka WATANABE, han reportado 3 vulnerabilidades, 2 de severidad alta y una media, todas de inyección SQL.

Solución:

Actualizar a las versiones 4.9.5 o 5.0.2 o posteriores. También se pueden aplicar los siguientes parches:

Detalle:

  • Un atacante, con acceso al servidor, podría aprovecharse de una vulnerabilidad de inyección SQL para crear un nombre de usuario, especialmente diseñado, y engañar a la víctima para que realice acciones específicas con esa cuenta de usuario. Además, podría generar errores en el servidor para los usuarios con ciertos caracteres que tratan de cambiar sus contraseñas de MySQL. Se ha asignado el identificador CVE-2020-10804 para esta vulnerabilidad.
  • Se ha descubierto una vulnerabilidad de inyección SQL en la que no se escapan correctamente ciertos parámetros al generar determinadas consultas para acciones de búsqueda dentro de phpMyAdmin, que permitiría a un atacante generar bases de datos o nombres de tablas especialmente diseñadas. Se ha asignado el identificador CVE-2020-10802 para esta vulnerabilidad.

Se ha asignado el identificador CVE-2020-10803 para la vulnerabilidad de severidad media.

Encuesta valoración

Etiquetas:
Actualización, PHP, Vulnerabilidad

Powered by WPeMatico

Gustavo Genez

Informático de corazón y apasionado por la tecnología. La misión de este blog es llegar a los usuarios y profesionales con información y trucos acerca de la Seguridad Informática.