Jailbreak para iOS 12.4 disponible: Sock_port exploit

Después de que Apple arreglaran para iOS 12.1.3 e iOS 12.3 los fallos que permitían el desarrollo del Jailbreak utilizado en iOS 12.1.2, han vuelto al mismo error en la versión 12.4, utilizando así el mismo sock_port y sock_puppet que se utilizaban en el anterior exploit. Esto supone un gran error por parte de Apple, ya que involuntariamente han abierto la opción de que un Jailbreak existente y que la compañía había resuelto en versiones previas, vuelva a funcionar en esta versión, algo sorprendente.

De este error se percato Ahmed Aldeab, y algunos usuarios tacharon esa información de fake, para después de comprobarlo, recapacitar y pedir disculpas a Ahmed (Siempre suelen salir usuarios con este tipo de fakes en el lanzamiento de una nueva versión de iOS, pero antes de acusar a alguien, mejor es comprobar que no sea verídico). Uno de los tweets con disculpas se puede ver a continuación:

Probablemente sea una de las primeras veces (si no la primera) que Apple comete semejante error, abre la puerta a exploits que ya estaban cerrados, y como era de esperarse el Jailbreak para iOS 12.4 ya está disponible y se puede bajar desde GitHub.

Figura 1: uncOver Jailbreak funcionando en iOS 12.4 (Fuente)

Seguramente muchos usuarios y desarrolladores quieran comprobar este fallo. Quedamos a la espera de ver como reacciona la compañía californiana ante este grave fallo de seguridad que proporciona la posibilidad de un Jailbreak.

Powered by WPeMatico

Gustavo Genez

Informático de corazón y apasionado por la tecnología. La misión de este blog es llegar a los usuarios y profesionales con información y trucos acerca de la Seguridad Informática.